Médiaforma

Excel pratique – Calculs conditionnels

Cette section vous montre comment effectuer un calcul en fonction d’une condition. Nous allons partir de la feuille de calcul suivante :

Nous allons remplir les cellules B12 et B13 en fonction des valeurs de la plage B2:B10.

Lorsqu’une valeur de cette plage est positive, elle intervient en tant qu’entrée. Lorsqu’elle est négative, elle intervient en tant que sortie. La cellule B12 contiendra la somme de toutes les valeurs positives de la plage B2:B10, et la cellule B13 la somme de toutes les valeurs négatives de cette même plage.

Pour arriver à ces résultats, vous allez utiliser la fonction SOMME.SI() dont voici la syntaxe :

=SOMME.SI(plage1; critère; plage2)

plage1 est la plage sur laquelle s’applique la fonction SOMME.SI(), critère est le critère appliqué aux cellules de la plage. Le paramètre plage2 est facultatif. Lorsqu’il n’est pas précisé, les valeurs de plage1 qui respectent le critère sont ajoutées. Lorsqu’il est précisé, les valeurs de plage2 dont les valeurs de plage1 qui respectent le critère sont ajoutées.

Cliquez dans la cellule B12 et entrez la formule suivante :

=SOMME.SI(B2:B10;">0")

Le premier paramètre désigne la plage de cellules à analyser et le deuxième le critère de sélection des cellules. Le troisième paramètre n’est pas précisé car les valeurs à additionner sont celles de la plage précisée dans le premier paramètre.

Cliquez dans la cellule B13 et entrez la formule suivante :

=ABS(SOMME.SI(B2:B10;"<0"))

Cette formule est proche de la précédente, si ce n’est que la somme doit porter sur les valeurs négatives (deuxième paramètre) et que le résultat affiché dans la cellule B13 doit être positif, d’où l’utilisation de la fonction ABS() pour obtenir la valeur absolue du résultat.

 
Commentaires

Bonjour, Je suis sous Excel 2016. J’ai recopié la formule =ABS(SOMME.SI(B2:B10;”<0")) en l'adaptant à mon cas. Et le résultat affiché est 0,00 quoiqu'il arrive. J'ai changé les formats de cellule en nombre mais rien n'y fait. Le résultat est toujours 0,00. Dans mon cas il s'agit ici uniquement de cellules négatives. Pouvez-vous m'aider ?

Je pense avoir trouvé d’où vient l’erreur, j’ai essayé sur un fichier .xls et cela fonctionne. En revanche mon fichier est .csv et cela me donne 0.00.

Laissez un commentaire