Médiaforma

Excel pratique – Calculer les jours fériés d’une année

Partagez cet article sur vos réseaux

Cette section va vous montrer comment calculer tous les jours fériés d’une année. Voici les formules utilisées, en supposant que l’année concernée est définie dans la cellule B1 :

Jour férié Formule
Jour de l’An =DATE(B1;1;1)
Pâques =ARRONDI(DATE(B1;4;MOD(234-11*MOD(B1;19);30))/7;0)*7-6
Lundi de Pâques =B3+1
Fête du travail =DATE(B1;5;1)
Victoire 1945 =DATE(B1;5;8)
Ascension =B3+39
Pentecôte =B3+49
Lundi de Pentecôte =B3+50
Fête Nationale =DATE(B1;7;14)
Assomption =DATE(B1;8;15)
Toussaint =DATE(B1;11;1)
Armistice 1918 =DATE(B1;11;11)
Noël =DATE(B1;12;25)

 

Le jour de l’An, la fête du travail, la Victoire de 1945, la Fête Nationale, l’Assomption, la Toussaint, l’Armistice de 1918 et le jour de Noël sont faciles à calculer car il s’agit de jours fixes dans l’année. Par exemple, la fête nationale a lieu le 14 Juillet, ou encore, Noël a lieu le 25 Décembre. La fonction DATE() est dont toute indiquée pour calculer les dates correspondantes.

La seule date difficile à calculer est Pâques. Le Lundi de Pâques, l’Ascension, Pentecôte et le Lundi de Pentecôte sont calculés à partir du jour de Pâques.

 
Commentaires

Merci pour ce tuto ..Excel n’est pas simple a prendre en main

Merci pour ce rappel. J’en ai eu besoin car mon tableau a sauté :(
Par contre, cette formule pour calculer Paques ne colle pas pour l’année 2022. Est-ce normal ?

Merci infiniment.

Bonjour concernant le calcul de Pâques pour l’année 2022 ( et d’ailleurs je rencontre ce problème pour toutes les années) le soucis est qu’en entrant votre formule j’obtient le résultant suivant  » 44668
 »
Comment régler ce soucis ? J’ai parfaitement suivi ce tuto pourtant. Merci par avance

Bonjour,

Affectez un format Date à la cellule dans laquelle se trouve le nombre 44668 et la date correspondante apparaîtra.

@Alexis

faut aller sur la case ou il y’a 44668, clique droite de ton sourie, choisir format de cellule ensuite date puis choisir le format de date que tu veux ensuite appliquer ou ok.

Bonjour,

Pensez à passer le format de votre cellule en Date ;)

Bonjour,
La formule ci-dessus n’est pas exacte, elle ne tient pas compte d’une correction assez rare qui survient certaines années. Le précédent échec est 1981, et le suivant sera 2049–Pâques tombe le 19 avril 1981 et le 18 avril 2049, mais la formule donne 26 et 25 avril respectivement ^^
Une façon de corriger la formule est
=ARRONDI(DATE(B1;4;MOD(234-11*MOD(B1;19);30)-QUOTIENT(MOD(B1*7+1;19);17))/7;0)*7-6
cette formule étant valide de 1900 à 2199. (Pour donner une idée, la formule inexacte produit seulement 6 erreurs sur cette période: 1954, 1981, 2049, 2076, 2106, 2133)

Bonjour Thibault,
De mon côté les 2 formules donnent des résultats identiques ! (Excel sous Mac Ventura 13.2.1)
Par contre les 2 formules donnent le (samedi) 8 avril 2023 pour « Pâques » au lieu du dimanche 9 avril !

Quelqu’un a-t-il une idée ?

Bonjour Olivier,

Prenons la formule étape par étape :)
Vérifiez que MOD(234-11*MOD(2023;19);30) = 15
Vérifiez que DATE(2023;4;15), soit le 15 avril 2023, est égal à 45031 si vous convertissez la cellule en nombre
Ensuite en principe, 45031 étant un multiple de 7, ARRONDI(45031/7;0)*7-6 devrait donner 45031-6 = 45025
Enfin, vérifiez que 45025 correspond bien au 9 avril 2023 si vous convertissez la cellule en date

Je pense que les numéros de série des dates seraient possiblement décalés d’un jour chez vous (le jour zéro serait chez vous le 30 décembre 1899 comme c’est le cas par défaut sur LibreOffice Calc, au lieu du 31 décembre 1899 normalement sous Excel). Si c’est le cas, vous obtenez alors 45032 pour le 15 avril 2023, que la formule arrondit au multiple de 7 le plus proche à savoir 45031, avant de retrancher 6 pour finir sur 45025 = 8 avril 2023 chez vous. La formule devient alors complètement fausse puisqu’elle renverrait toujours un samedi chez vous, il faudrait alors la corriger en
=ARRONDI(DATE(B1;4;MOD(234-11*MOD(B1;19);30)-QUOTIENT(MOD(B1*7+1;19);17)-1)/7;0)*7-5

Quant à la correction que j’applique, il serait alors complètement normal qu’elle n’apparaisse pas dans votre cas pour les années que j’ai citées, mais devrait probablement apparaître pour d’autres années. Peu importe, puisque si la formule vous donne systématiquement un samedi, elle est fausse quoi qu’il en soit.

Re,

Excel sous Mac peut également utiliser le 1er janvier 1904 comme jour zéro, auquel cas le 15 avril 2023 correspond à 43569, arrondi au multiple de 7 le plus proche qui est 43568, auquel on enlève 6 = 43562 = 8 avril 2023 dans ce système. Cela revient exactement au même, puisque tant le 30 décembre 1899 que le 1er janvier 1904 sont des vendredis, donc les multiples de 7 sont des vendredis dans les deux cas. (Alors que sous Excel pour Windows, les multiples de 7 sont des samedis)

compta@cclpa.fr

Bonjour
super tableur, maintenant j’ai une autre question comment comptabiliser dans cette liste les jours fériés hors samedi et dimanche ?
Merci pour votre réponse

Hello
Tu ajoutes une colonne pour tester les différentes dates avec la fonction « joursem »
Exemple : « =SI(OU(JOURSEM(cellule à tester)=1;JOURSEM(cellule à tester)=7);0;1) » ensuite tu fais une somme.

Je vous remercie infiniment pour ce poste
j’apprends à utiliser Excel pour la bureautique et gérer la compta.

Trackbacks for this post

Laissez un commentaire