Médiaforma

Excel pratique – Calculer les jours fériés d’une année

Partagez cet article sur vos réseaux

Cette section va vous montrer comment calculer tous les jours fériés d’une année. Voici les formules utilisées, en supposant que l’année concernée est définie dans la cellule B1 :

Jour férié Formule
Jour de l’An =DATE(B1;1;1)
Pâques =ARRONDI(DATE(B1;4;MOD(234-11*MOD(B1;19);30))/7;0)*7-6
Lundi de Pâques =B3+1
Fête du travail =DATE(B1;5;1)
Victoire 1945 =DATE(B1;5;8)
Ascension =B3+39
Pentecôte =B3+49
Lundi de Pentecôte =B3+50
Fête Nationale =DATE(B1;7;14)
Assomption =DATE(B1;8;15)
Toussaint =DATE(B1;11;1)
Armistice 1918 =DATE(B1;11;11)
Noël =DATE(B1;12;25)

 

Le jour de l’An, la fête du travail, la Victoire de 1945, la Fête Nationale, l’Assomption, la Toussaint, l’Armistice de 1918 et le jour de Noël sont faciles à calculer car il s’agit de jours fixes dans l’année. Par exemple, la fête nationale a lieu le 14 Juillet, ou encore, Noël a lieu le 25 Décembre. La fonction DATE() est dont toute indiquée pour calculer les dates correspondantes.

La seule date difficile à calculer est Pâques. Le Lundi de Pâques, l’Ascension, Pentecôte et le Lundi de Pentecôte sont calculés à partir du jour de Pâques.