Médiaforma

All posts in excel-pratique

Vous voulez colorer toutes les lignes dont une cellule spécifique est vide ? Rien de plus simple avec une mise en forme conditionnelle.

Sélectionnez toute la feuille de calcul en cliquant sur la case à l’intersection des en-têtes de lignes et de colonnes ou avec le raccourci clavier Contrôle + A :

Sous l’onglet Accueil du ruban, dans le groupe Styles, cliquez sur l’icône Mise en forme conditionnelle puis sur Nouvelle règle. La boîte de dialogue Nouvelle règle de mise en forme s’affiche :

Dans la zone Sélectionnez un type de règle, cliquez sur Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué. Supposons que vous vouliez colorer en orange les lignes pour lesquelles la cellule de la colonne D n’est pas remplie. Tapez la formule suivante dans la zone de texte Appliquer une mise en forme aux valeurs pour lesquelles cette formule est vraie :

=$D1=""

Cliquez sur le bouton Format. Cette action affiche la boîte de dialogue Format de cellule. Basculez sur l’onglet Remplissage, puis choisissez la couleur orange :

Validez en cliquant sur OK. La boîte de dialogue Nouvelle règle de mise en forme doit maintenant ressembler à ceci :

Validez en cliquant sur OK. Toutes les lignes devraient avoir un fond orange.

Renseignez la colonne D de quelques lignes. Ces lignes perdent alors la couleur orange :


Lorsque vous calculez des sommes ou des moyennes par exemple, les calculs sont faussés si Excel rencontre des cellules vides sur la plage concernée par le calcul. Pour corriger ce problème, vous devez supprimer les cellules vides. Cela peut se faire manuellement, cellule par cellule, mais vous pouvez aller beaucoup plus vite.

Sélectionnez le bloc de cellules qui contient les cellules vides à supprimer. Appuyez sur la touche de fonction F5. La boîte de dialogue Atteindre s’affiche. Cliquez sur le bouton Cellules. La boîte de dialogue Sélectionner les cellules s’affiche. Sélectionnez l’option Cellules vides et cliquez sur OK :

Seules les cellules vides sont maintenant sélectionnées :

Appuyez simultanément sur les touches Contrôle et . La boîte de dialogue Supprimer s’affiche. Sélectionnez une option pour décaler les cellules non vides puis cliquez sur OK :


Les erreurs de calcul sont fréquentes dans les formules. Cet article va vous montrer comment personnaliser ce qui s’affiche dans une cellule en cas d’erreur. Pour cela, vous utiliserez la fonction SIERREUR(). Voici sa syntaxe :

=SIERREUR(calcul;"chaîne")

Où :

  • calcul est un calcul quelconque.
  • chaîne est la chaîne qui s’affiche dans la cellule si une erreur se produit sur le calcul.

Si le calcul ne produit pas d’erreur, il est affiché dans la cellule. S’il produit une erreur, c’est la chaîne spécifiée en deuxième argument qui est affichée.

Pour voir comment utiliser cette fonction, nous allons raisonner sur un exemple :

Dans la colonne C, le prix unitaire est calculé en divisant la cellule Total (colonne A) par la cellule Quantité (colonne B) correspondante. Si la cellule B est vide, une erreur se produit, comme dans les lignes 4 et 6.

Pour corriger cela, vous allez remplacer le calcul =A3/B3 de la cellule C3 par cette formule :

=SIERREUR(A3/B3;"Quantité absente")

Utilisez la poignée de recopie pour recopier la formule jusqu’à la cellule C8. Voici le résultat :


Par défaut, les nouveaux classeurs contiennent trois feuilles. Vous voulez plus ou moins de feuilles ? C’est possible. Basculez sur l’onglet Fichier du ruban et cliquez sur Options. La boîte de dialogue Options Excel s’affiche. Sous l’onglet Général, dans le groupe d’options Lors de la création de classeurs, agissez sur la zone de texte Inclure ces feuilles. Ici par exemple, les nouveaux classeurs comporteront une seule feuille à leur ouverture :

Remarque

Dans le même groupe d’options, vous pouvez choisir la police et la taille des caractères.

Une fois la boîte de dialogue entièrement paramétrée, cliquez sur OK pour appliquer le nouveau réglage.


Sélectionnez toute la feuille de calcul en cliquant sur la case à l’intersection des en-têtes de lignes et de colonnes ou avec le raccourci clavier Contrôle + A :

Sous l’onglet Accueil du ruban, dans le groupe Styles, cliquez sur l’icône Mise en forme conditionnelle, puis sur Nouvelle règle. La boîte de dialogue Nouvelle règle de mise en forme s’affiche. Sous Sélectionnez un type de règle, choisissez Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué.

Pour colorer les lignes impaires, vous utiliserez cette formule :

=MOD(LIGNE() ;2)

La fonction MOD() applique un modulo 2 sur le numéro de ligne. Elle retourne 0 si la ligne est paire, 1 si la ligne est impaire. La mise en forme s’appliquera donc aux lignes impaires.

Pour colorer les lignes paires, vous utiliserez cette formule :

=NON(MOD(LIGNE() ;2))

L’opérateur NON() inverse la formule précédente. La mise en forme s’appliquera donc aux lignes paires.

Selon l’effet recherché, entrez une de ces deux formules dans la zone de texte du cadre inférieur.

Cliquez sur le bouton Format. La boîte de dialogue Format de cellule s’affiche. Basculez sur l’onglet Remplissage et choisissez une couleur de remplissage :

Validez en cliquant sur OK. La boîte de dialogue Nouvelle règle de mise en forme doit maintenant ressembler à ceci :

Validez en cliquant sur OK. Une ligne sur deux est colorée :


Si vous avez suivi la formation Excel 2016, vous savez qu’il est très facile de redimensionner une colonne à la largeur maximale de ses cellules en double-cliquant sur la partie droite de son en-tête :

Saviez-vous que vous pouvez redimensionner automatiquement toutes les colonnes en une seule opération ?

Cliquez à l’intersection des en-têtes de ligne et de colonne ou appuyez sur Contrôle + A pour sélectionner la totalité de la feuille de calcul :

Il vous suffit maintenant de double-cliquer dans la partie droite d’un en-tête de colonne pour redimensionner automatiquement toutes les colonnes :


Par défaut, les cellules des feuilles de calcul sont encadrées par un quadrillage gris clair. Pour changer la couleur de ce quadrillage, basculez sur l’onglet Fichier du ruban et cliquez sur Options. La boîte de dialogue Options Excel s’affiche. Basculez sur l’onglet Options avancées et déplacez la barre de défilement pour atteindre la section Options d’affichage de la feuille de calcul. Vérifiez que la case Afficher le quadrillage est bien cochée et choisissez la couleur du quadrillage dans la liste déroulante :