Médiaforma

Excel pratique – Nombre d’occurrences d’un élément

Print Friendly, PDF & Email

La fonction NB.SI() permet de trouver le nombre de cellules qui répondent à un critère. Voici sa syntaxe :

=NB.SI(plage; critère)

plage est la plage de cellules examinée et critère est le critère de sélection.

Le critère peut être un nombre, une comparaison numérique, une chaîne sans ou avec caractères génériques ou encore la référence à une cellule.

Pour bien comprendre comment utiliser cette fonction, nous allons raisonner sur plusieurs exemples.

Recherche d’un nombre

Pour compter le nombre de cellules de la plage C5:E15 égales à 33 dans la cellule I5, vous utiliserez cette formule :

=NB.SI(C5:E15;33)

Comparaison numérique

Pour compter le nombre de cellules de la plage C5:E15 inférieures à 100 dans la cellule I6, vous utiliserez cette formule :

=NB.SI(C5:E15;"<100")

Chaîne sans caractères générique

Pour compter le nombre de cellules de la plage B5:B15 qui contiennent la chaîne Elise, vous utiliserez cette formule :

=NB.SI(B5:B15;"Elise")

Chaine avec caractères génériques

Pour compter le nombre de cellules de la plage B5:B15 qui commencent par la lettre P, vous utiliserez cette formule :

=NB.SI(B5:B15;"P*")

Référence à une cellule

Enfin, pour compter le nombre de cellules de la plage C5:E15 qui contiennent la valeur de la cellule H3, vous utiliserez cette formule :

=NB.SI(C5:E15;H3)
Vous avez aimé cet article ? Partagez-le avec vos réseaux...
 
Comments

No comments yet.