Médiaforma

Excel pratique – Personnaliser la gestion des erreurs

Print Friendly, PDF & Email

Les erreurs de calcul sont fréquentes dans les formules. Cet article va vous montrer comment personnaliser ce qui s’affiche dans une cellule en cas d’erreur. Pour cela, vous utiliserez la fonction SIERREUR(). Voici sa syntaxe :

=SIERREUR(calcul;"chaîne")

Où :

  • calcul est un calcul quelconque.
  • chaîne est la chaîne qui s’affiche dans la cellule si une erreur se produit sur le calcul.

Si le calcul ne produit pas d’erreur, il est affiché dans la cellule. S’il produit une erreur, c’est la chaîne spécifiée en deuxième argument qui est affichée.

Pour voir comment utiliser cette fonction, nous allons raisonner sur un exemple :

Dans la colonne C, le prix unitaire est calculé en divisant la cellule Total (colonne A) par la cellule Quantité (colonne B) correspondante. Si la cellule B est vide, une erreur se produit, comme dans les lignes 4 et 6.

Pour corriger cela, vous allez remplacer le calcul =A3/B3 de la cellule C3 par cette formule :

=SIERREUR(A3/B3;"Quantité absente")

Utilisez la poignée de recopie pour recopier la formule jusqu’à la cellule C8. Voici le résultat :

Vous avez aimé cet article ? Partagez-le avec vos réseaux...