Médiaforma

Excel pratique – Plus de critères dans une somme conditionnelle

Print Friendly, PDF & Email

La fonction SOMME.SI.ENS() permet de faire la somme des cellules d’une colonne lorsque les cellules correspondantes dans une autre colonne respectent un ou plusieurs critères.

Pour bien comprendre comment utiliser cette fonction, nous allons raisonner sur une pyramide des âges :

Les données numériques s’étalent de la ligne 7 (année de naissance 2017) à la ligne 106 (année de naissance 1918).

Voici la syntaxe de la fonction SOMME.SI.ENS() :

=SOMME.SI.ENS(plage1;plagecritère1;critère1;plagecritère2;critère2;…)

Où :

  • plage1 est la plage qui contient les cellules à sommer.
  • plagecritère1 est la plage sur laquelle le critère critère1 sera appliqué.
  • Plagecritère2 est la plage sur laquelle le critère critère2 sera appliqué.
  • .

Nous allons utiliser la fonction SOMME.SI.ENS() pour calculer le nombre de femmes entre 20 et 30 ans. Voici la formule utilisée :

=SOMME.SI.ENS(C7:C106;B7:B106;">=20";B7:B106;"<=30")

Calculons maintenant le nombre d’hommes au-delà de 60 ans. Voici la formule utilisée :

=SOMME.SI.ENS(D7:D106;B7:B106;">=60")

Remarque

En utilisant la même syntaxe, vous pourriez utiliser la fonction NB.SI.ENS() pour calculer le nombre de lignes qui correspondent à un ou plusieurs critères, ou encore la fonction MOYENNE.SI.ENS() pour calculer la moyenne des cellules qui correspondent à un ou plusieurs critères.

Vous avez aimé cet article ? Partagez-le avec vos réseaux...
 
Comments

No comments yet.