Médiaforma

LibreOffice Calc – Les fonctions dédiées aux chaînes

Print Friendly, PDF & Email

Il existe de nombreuses fonctions dédiées aux chaînes de caractères dans Calc. Vous les utiliserez pour remplir des cellules à partir d’autres cellules existantes. En voici quelques-unes :

Fonction Signification
MAJUSCULE() et MINUSCULE() Version majuscule et minuscule de la chaîne passée en argument
SUBSTITUE() Remplace un texte par un autre dans une chaîne
CHERCHE() Recherche une sous-chaîne dans une chaîne
NBCAR() Nombre de caractères de la chaîne passée en argument
CONCATENER() Concatène les chaînes passées en argument

 

Pour illustrer ces fonctions, nous allons raisonner sur cette feuille de calcul :

Les colonnes E à H sont calculées à partir des colonnes A à D :

  • La colonne E est obtenue en assemblant les données de la colonne C et de la colonne D mise en majuscules.
  • La colonne F est obtenue en remplaçant la lettre “A” par la lettre “a” dans les données de la colonne A.
  • La colonne G recherche la sous-chaîne “er” dans les cellules de la colonne B. Elle affiche la position de cette sous-chaîne ou un code d’erreur si la sous-chaîne n’est pas trouvée.
  • La colonne H est une amélioration de la colonne G. Elle affiche trouvé si la sous-chaîne “er” est trouvée dans les cellules de la colonne B. Elle affiche non trouvé dans le cas contraire.

Voici les formules utilisées :

  • Cellule E2: =CONCATENER(C2;” “;MAJUSCULE(D2))
  • Cellule F2: =SUBSTITUE(A2;”A”;”a”)
  • Cellule G2: =CHERCHE(“er”;B2)

Comme vous le voyez, un code d’erreur s’affiche dans la colonne G lorsque la chaîne “er” n’est pas trouvée dans les cellules de la colonne B. Pour améliorer le comportement de la fonction CHERCHE(), vous allez tester la valeur renvoyée par cette fonction dans la fonction ESTERR(). Si une erreur est retournée (#VALEUR!), la chaîne “non trouvé” sera affichée. Sinon, la chaîne “trouvé” sera affichée. Rien de plus simple grâce à la fonction SI(). Voici la formule utilisée pour calculer la cellule H2 :

=SI(ESTERR(CHERCHE(“er”;B2));”non trouvé”;”trouvé”)

Pour compléter les cellules des lignes 3 à 12, il suffit de recopier tour à tour les cellules E2, F2, G2 et H2 jusqu’en E12, F12, G12 et H12.

Vous avez aimé cet article ? Partagez-le avec vos réseaux...